Overview
FogBugz might stop pulling and/or sending emails from GMail unexpectedly.
The issue might persist or reappear even after executing the following steps:
- Re-adding (editing) the password into the mailbox account in FogBugz, and pressing the button "Start downloading messages"
- Making sure Less Secure App access is enabled in the Gmail account
- Reviewing Recent Security Activity in GMail account and checking and confirm that "This is me"
- Changing the Gmail password and trying again with a new password in the Fogbugz Mailbox
Information
Root Cause
Using a username and password by third-party applications (like FogBugz) to login to GMail is considered less secure. This is why Google calls it less secure apps access.
To ensure that only authorized third-party apps are using your username and password, GMail asks you regularly for confirmation, but this confirmation is "hidden" in Recent Security Activity of your Manage your Google Account settings. And if you are not quick enough to confirm, the login will be denied. Confirming it later does not allow FogBugz to access the emails.
Less secure apps are beginning to be shut off by Google. This is why it is recommended to turn off less secure apps in your GMail account and start using application passwords instead for providing access to FogBugz Mailboxes.
Solution
The solution is to change your GMail to use two-factor authentication and to change your FogBugz Mailbox settings to use application passwords for accessing your GMail account.