Overview
Upon upgrading FogBugz and attempting to log in, you may get the following error message:
There was a problem with your search string!
Invalid search response!
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This article explains the root cause and provides the steps to diagnose and resolve this error.
Environment
FogBugz On-Premises version 8.22.36 & 8.22.135 on a Windows server.
Root Cause
The registry key for the ElasticSearch JVM points to the incorrect JDK version.
Process
Diagnosis
The error message received is related to Java. You can validate this by checking the following:
- In the Windows Command Console (CMD), run the following command.
ECHO %JAVA_HOME%
The system retrieves the path to the latest Java Developer Kit version installed. If the upgrade was correctly installed, the path indicates the versionjdk1.8.0_162
, which is the latest version packed with FogBugz 8.22.x. - Check the value of the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apache Software Foundation\Procrun 2.0\FogBugz ElasticSearch\Parameters\Java
If the value of the Jvm key, as shown in the image above, shows a different java version than the version you received in step 1, then it causes ElasticSearch to fail after the upgrade.
In our example, the version mentioned in the Jvm key isjdk1.7.0_80
, which does not match with the version seen in step 1, causing ElasticSearch to fail after the upgrade.
Resolution
- Copy the value of the Java version obtained in Step 1 of the Diagnosis process. In our example, it is
jdk1.8.0_162
. - Replace the Java version in the Jvm key with this version value, as shown in the image below.
- Restart the FogBugz ElasticSearch service.
Confirmation
Log out and then log in to reload the site. Now try accessing the case listing in FogBugz, and it should start showing filters, case listing, and searches without any error.