Unable to Export All Fields When Using 'Export to CSV' Filter


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Overview

 

Sometimes, when you try to use the Export to CSV feature, you notice that:

  • You cannot export more columns by clicking Select Columns and adding more fields to be exported to CSV.
  • Your current filter is disregarded and, based on the total filter result, all the cases are exported.

This article describes the root cause and resolution of these issues.

 


Environment

 

  • FogBugz On-Site
  • Manuscript On-Premise
  • FogBugz On-Premise

 

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Root Cause

 

The Export to CSV feature is not enabled.

 

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Resolution

 

To resolve the issue, you must enable the ClientSideCSVExport functionality by following the steps mentioned below:

  1. Navigate to the http://<Your Site URL>/f/debug page.

  2. Click Account Feature Switches on the Debug Page.

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  3. Search for ClientSideCSVExport in the list of feature switches. In the Trial Override column, select Force Enable from the dropdown menu and then click Update.

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Validation

 

The following section describes the difference when the feature is enabled and disabled.

Note: You should have at least 50 or more cases to notice the difference.

  • Disabled: The Export to CSV will disregard what your current filter is and will export the total number of cases of your filter results.

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  • Enabled: The Export to CSV will consider your current filter, for example, in this case, it will only export 50 out of the total number of cases.

    download3.png

 

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Additional Information

 

You will be able to select and add more columns by clicking Select Columns. These columns will also be included once you select the export to CSV feature.

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