Connectivity Issues When Accessing FTPS to Download FogBugz Database Backup


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Overview

You receive the error "GnuTLS error -110: The TLS connection was non-properly terminated" while connecting to FogBugz FTPS server (File Transfer Protocol Secure Server) after the backup of the database.

Status: Connection established, waiting for welcome message...
Response: 220 Welcome to the Fog Creek Support FTP server. Files on this server are regularly cleaned out, so please don't use it as long-term storage!
Command: AUTH TLS
Response: 234 Proceed with negotiation.
Status: Initializing TLS...
Error:  GnuTLS error -110: The TLS connection was non-properly terminated.
Status: Server did not properly shut down TLS connection
Error:   Could not connect to server

This article provides a fix to rectify the FTPS connection error messages.


Diagnosis

This problem can be caused by one or several of the following:

  • the correct port number is missing
  • the server name is incorrect.

Important! We changed the backup server domain name starting from July 2019. Please use ftpny.fogbugz.com instead of ftpny.fogcreek.com when connecting to the backup server.


Solution

Please check the solution for the most popular FTPS clients:

FileZilla

  • Most of the time, this issue can be fixed by using FileZilla and connecting via FTPS (not to be confused with SSH File Transfer Protocol (SFTP) connections).
  • Make sure you are using the correct domain name: use ftpny.fogbugz.com instead of ftpny.fogcreek.com.
  • FTPS connections must be implicit FTPS connections, and you must specify port 990 to assure your client will establish a connection.
    If your backup needed to be provided manually by the support team and you are connecting to our support-ftp.versata.com server, than you will need to use port 22.

 

WinSCP

  • This FTP client is known to present difficulties to connect to our FTPS server. It is recommended to use FileZilla if possible.

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