License Issue after Moving FogBugz to a New Server


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Overview

When moving your On-Premise FogBugz to a new server your license gets invalidated, since it is linked to the Machine ID / SID, which is unique to each Server. The same issue happens when your FogBugz database is accessed through a new website (as in two load-balanced web servers accessing the same database).


Diagnosis

All information FogBugz needs to run is contained in its database. You should back this database up before any move. When FogBugz runs, it checks the licenses on the current install to determine how many users can be logged onto the system.

FogBugz license files have three components:

  • Email address used to sign up
  • Order number
  • Machine ID/SID of the machine where the website is hosted

Thus, when you move to a new server (machine), or when you access a FogBugz database through a new website (as in two load-balanced web servers accessing the same database), the license will not match the machine ID.

 


Solution

The solution is to reapply the license on the new server (machine).

The steps to execute are the same as when Adding Additional FogBugz Licenses.

In case you face any issues while applying the licenses, follow the troubleshooting steps from that article.

 


Related articles

Adding Additional FogBugz Licenses