Overview
This article describes the resolution of an issue, which occurs when the timesheets do not reflect the user's time zone accurately and are creating split entries for existing entries.
Information
Environment
All the versions of FogBugz on any browser.
Root Cause
If the time zone is manually changed on the user machine or the browser, the entries do not display in the current timezone.
Steps to Reproduce
Note: Only if automatically start and stop work is disabled.
- Set your user's time zone to EST.
- Edit the timesheet for yesterday (starting with an empty timesheet).
- Add an interval from 12:00 PM to 11:30 PM, and save the timesheet.
- Change your user's time zone to UTC.
- Edit yesterday's timesheet to add an interval from 11:30 PM to 11:50 PM.
- Save the timesheet, reload the page, and view yesterday's timesheet again.
- The timesheet will show that the original entry was split into two separate entries as shown in the screenshot below. The times are also wrong, as we are now 5 hours ahead in time zones, but the original split timesheet entries still show in EST.
Resolution
Change the timezone to the correct zone from the regional settings. You can also change the timezone from the user options.