Browser Hangs, no page is displayed


Follow

Issue:

FogBugz hangs and doesn’t seem to do anything after submitting a webpage, with Norton AntiVirus or McAfee Virus Scan installed on the server

Environment:

FogBugz for your server, windows server os, Norton Antivirus or McAfee latest version

Audience:

Agent-Only

Root Cause:

Both AV’s have a special feature that interferes with the execution of certain ASP pages. Norton Calls this “script blocking” and McAfee calls it a “script stopper utility” and they prevent scripts (in this case .asp pages) from writing files to the hard drive.

Resolution:

  • Disable this “script blocking” feature in whichever anti-virus software is running on your web server
  1. Norton Antivirus:
  1. Right-click on the Norton icon in the taskbar
  2. Choose ‘Configure Norton Antivirus’.
  3. Clear the checkbox marked Script Blocking to turn off Script Blocking

*Note: Norton AntiVirus is not intended to be used on servers.*

  1. McAfee Antivirus:
  1. Go to McAfee Advanced ActiveShield Options
  2. Click on the ScriptStopper tab
  3. Clear the checkbox marked Enable ScriptStopper
  • After disabling it, restart IIS completely in order to clear out the hung process.
  1. Open Internet Services Control Panel (Start>Run>Control Panel>Administrative Tools>Internet Service Manager)
  2. Right click on the server icon and choose Restart IIS