Error: “The Fog Creek Platform is Unavailable”


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Error Message

This error generally happens when the Kiln settings get out of sync with FogBugz.

The Fog Creek platform is unavailable.

Root Cause

  • Deleted and recreated Kiln Database (DB).
  • Failed installation or upgrade.

WorkAround / Fix

The fix for this is pretty straightforward.

  1. Run this SQL query against your FogBugz database:
    DELETE FROM PluginKeyValue WHERE sKey = 'sKilnSecurityToken'
  2. From the computer where Kiln is installed, go to the following URL:
    • http://your/kiln/Setup/Go
    • If Kiln is installed at http://your/kiln, you must hit this from the server itself using a hostname that resolves to a local IP, e.g. localhost
    • You should get the response: OK
    • If you do not get this response, then you most likely got an error page. In which case, you’ll need to go to http://your/kiln/Setup/Go and send the stack trace to FogBugz Customer Service by submitting a request at FogBugz Support.

NOTE: In some cases, you might have to manually run the following statement on the Kiln database:

UPDATE Setting SET sValue = 0 WHERE sKey LIKE 'fFogBugzUnavailable'