Missing Login Boxes (FogBugz On-Premises)


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Overview

After restoring your FogBugz On-Premises database it might happen that your login boxes are missing and you are not able to log in as Administrator to continue the Upgrade process. Typically this might happen during an upgrade process or when restoring your database to a test environment.

LoginBox_Unavailable.jpg

 


Diagnosis

FogBugz displays login boxes depending on what type of authentication you use. For LDAP or Active Directory (AD) authentication, there is no need to display the login box, because FogBugz can use the LDAP or AD credentials for integrated (seamless) authentication.

Starting from Manuscript On-Site version 8.16 LDAP and AD authentications are not supported anymore.

The configuration setting deciding what type of authentication should FogBugz use (and whether to show the login boxes), is stored in FogBugz' database in the Setting table.

When you restore a FogBugz database in a testing or staging environment, using a backup from the production environment, or when you migrate or upgrade from an earlier version, these configuration settings in the database might be set in a way to hide the login boxes.

 

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Prerequisites

  • Administrator access to the SQL Database of the affected FogBugz instance
  • Knowledge of using Microsoft SQL Server Management Studios (SSMS)

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Solution

The recommended solution in such cases is to change the authentication type to the default username and password authentication, log in to FogBugz and reconfigure the authentication to a currently supported type (for example SAML Single Sign-On (SSO)).

 

Configuration Settings depending on your FogBugz Version

To enable logging in with user name and password (to show the login boxes), the following values need to be set in the Setting table, depending on your FogBugz version:

  • FogBugz versions before 8.16: fPasswordEnable and fLogOnTextBox need to be set to 1
  • FogBugz versions 8.16 and later: iAuthType needs to be set to 0

After you are able to log in as Administrator, you can use the Site Configuration -> Authentication settings to configure a different and supported type of authentication.

 

Updating the Configuration Settings

We prepared for you a script that can be run on any FogBugz version to fix the missing login boxes issue.

Steps for updating the values:

    1. Login to the SQL Database of the affected FogBugz Instance using SSMS.
    2. Run the following script to update the values (change trial1 database name to your own trialN database):
      USE trial1
      
      -- Update fPasswordEnable and fLogOnTextBox for FogBugz earlier then v8.16
      -- If you are using FogBugz v8.16 or later, these values will have no effect on your FogBugz. This is why we are not going to insert them, just update them if they exist.
      UPDATE Setting SET sValue = 1 WHERE sKey = 'fPasswordEnable'
      UPDATE Setting SET sValue = 1 WHERE sKey = 'fLogOnTextBox'
      
      -- Insert iAuthType if it doesn't exists
      -- If your are using FogBugz version earlier then v8.16 this configuration value will have no effect on your FogBugz.
      INSERT INTO Setting
      (sKey, sValue)
      SELECT insertData.sKey, insertData.sValue 
      FROM Setting sourceData
      RIGHT JOIN (Select 'iAuthType' as sKey, 0 as sValue) insertData
        ON sourceData.sKey = insertData.sKey 
      WHERE sourceData.sKey IS NULL 
      
      -- Update iAuthType to default value 0 to enable login boxes.
      UPDATE Setting SET sValue = 0 WHERE sKey = 'iAuthType'


    3. Run the following query to check the updated values:
      SELECT * FROM dbo.Setting WHERE sKey IN ('iAuthType', 'fPasswordEnable', 'fLogOnTextBox')

 

You can find the script attached to this article for your convenience.

 

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Testing

After updating these parameters, the login boxes are displayed.

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