Upgrading FogBugz On-Premises, Windows Server, or SQL Server


Follow

Overview

When evaluating the FogBugz On-Premises upgrade options, usually the following typical cases are considered:

  • Upgrading FogBugz FYS 8.8.55 (or older versions) to the latest version
  • Upgrading Windows Server (eg: from Windows 2008 R2 to Windows 2012, 2016, or 2019)
  • Upgrading SQL Server (eg: from SQL Server 2014 to SQL Server 2019)

 


Information

 

Upgrade Paths

Check out the Compatibility of FogBugz With Windows Operating Systems and SQL Servers.

You will notice that there are three main upgrade paths:

  • Upgrading FYS to the latest version
    • Windows upgrade is needed
    • SQL Server upgrade is needed
  • Upgrading the Windows Server (and IIS)
    • Upgrading to Windows 2012 R2 or later requires FogBugz upgrade if your FogBugz version is FYS (8.8.55) or older
  • Upgrading the SQL Server
    • Upgrading to SQL Server 2014 or later requires FogBugz upgrade if your FogBugz version is FYS (8.8.55) or older

If you anyhow need to upgrade your FogBugz, we recommend upgrading to the latest version.

Notice in our current System Requirements that Windows Server 2019 is NOT officially supported yet.

 

FogBugz License Costs

Upgrading from FogBugz FYS 8.8.55 or older version to any FogBugz version later than 8.8.55 will require you to buy a new FogBugz license. To get a quote you will need to contact the Renewals Team.

 

Additional License Costs

FogBugz On-Premises does NOT include any Windows or Microsoft SQL Server licenses. You will need to acquire those separately from your Microsoft Licensing partner.

 

Cost Reduction

If you move to FogBugz On-Demand, your costs will be easier to calculate since FogBugz On-Demand costs depend only on the number of users and features used. The operating system, database server, and maintenance costs are all included since it is a cloud service (SaaS). You can try it out for free, no credit card required.

 

Supported Operating Systems

Linux is no more a supported operating system. The list of currently supported operating systems is available in the System Requirements.

 

Database Support

MySQL is not supported anymore, but our Professional Services is here to help you move to Microsoft SQL Server after you get an additional quote from Succes Team for the migration work.

 

Supported Kiln versions

Kiln FYS or any Kiln on-premises version is not supported anymore. The only supported Kiln version is Kiln On-Demand.

 

Supported Web Browsers

The list of supported web browsers also changed since FogBugz FYS. Please read about the latest supported web browsers.

 

Upgrade Process

 

Back to the top