Heartbeat Pinger Log File Increasing Rapidly - FogBugz On-Premises


Follow

Overview

You notice that your Heartbeat Pinger service's log file is increasing rapidly.

You might also notice similar log items in the log file:

http://localhost/0/multiheartbeat.asp

You might also experience that some of your FogBugz's functionalities might not work correctly (ex. mail sending, or mail receiving).

 


Information

 

Diagnosis

You might find something similar in your log file at regular intervals (depending on your configuration this can be at every second).

2020-12-18 17:28:23,749 INFO 5 pinger - {
  "sFBHostedConnectionString": "Server=YourDBServer;Initial Catalog=fbhosted;MultipleActiveResultSets=true;Integrated Security=SSPI;",
  "pingerSettings": [
    {
      "url": "http://localhost/822180000/multiheartbeat.asp?nPriority=1",
      "nConcurrentRequests": 0
    },
    {
      "url": "http://localhost/822180000/multiheartbeat.asp?nPriority=2",
      "nConcurrentRequests": 0
    },
    {
      "url": "http://localhost/822180000/multiheartbeat.asp",
      "nConcurrentRequests": 1
    },
    {
      "url": "http://localhost/822180000/trialActivate.asp",
      "nConcurrentRequests": 1
    },
    {
      "url": "http://localhost/0/multiheartbeat.asp?nPriority=1",
      "nConcurrentRequests": 0
    },
    {
      "url": "http://localhost/0/multiheartbeat.asp?nPriority=2",
      "nConcurrentRequests": 0
    },
    {
      "url": "http://localhost/0/multiheartbeat.asp",
      "nConcurrentRequests": 1
    },
    {
      "url": "http://localhost/0/trialActivate.asp",
      "nConcurrentRequests": 1
    },
    {
      "url": "http://localhost/0/trialEmail.asp",
      "nConcurrentRequests": 1
    }
  ]
}

Notice that you have several entries pointing to:

http://localhost/0/

instead of

http://localhost/822180000/

which is the correct localhost path to your FogBugz website.

 

Root Cause

This can be because of an incorrectly updated or missing value for ixGeneration in the fbhosted database in the table tblDefaultGeneration.

 

Solution

The solution is to update the correct value in the mentioned configuration table.

The value of ixGeneration should match the version of FogBugz, but without the dots in the version number, followed by three trailing zeros.

For example: in the case of the FogBugz version 8.22.180 the value of ixGeneration should be 822180000.

Use the following steps to update the value of ixGeneration:

  1. Connect to your SQL Server using SSMS.

  2. Delete all of the content of the table using the following SQL statement:
    DELETE FROM [fbhosted].[dbo].[tblDefaultGeneration]


  3. Insert the correct value using the following SQL statement:
    INSERT INTO [fbhosted].[dbo].[tblDefaultGeneration] ([ixGeneration]) VALUES (822180000)
    The value used should be the same as the one in the correct localhost path of your FogBugz instance. In our example this was 822180000.

  4. Verify that the correct value has been added by using this SQL Statement:
    SELECT [ixGeneration] FROM [fbhosted].[dbo].[tblDefaultGeneration]
    The result should contain only one record.

  5. Restart the FogBugz Heartbeat Pinger service using the Services Windows control panel. HeartbeatPinger_Restart.jpg

  6. Verify your Heartbeat Pinger log file. The http://localhost/0/ lines should not be added anymore.

  7. If you had any FogBugz feature not working (like email sending/receiving) verify that it started working again.

 

Back to the top